summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorJason Ekstrand <jason.ekstrand@intel.com>2014-07-24 11:17:53 -0700
committerJason Ekstrand <jason.ekstrand@intel.com>2014-08-04 11:07:15 -0700
commit992e1ea8e4290cf14d59f89415bfd13e0920aad7 (patch)
tree1e3ce418960e77e5926e8e76d0f4bd9244e38caa /src/util/Makefile.am
parentefa0aa8ffc63e8fdd23335e67ca76eb358cfd1ac (diff)
gallium: Move sRGB <-> RGB handling to libmesautil
Signed-off-by: Jason Ekstrand <jason.ekstrand@intel.com> Reviewed-by: Marek Olšák <marek.olsak@amd.com>
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index a2aeafc703b..e738ab08d2f 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -23,6 +23,10 @@ SUBDIRS = . tests
include Makefile.sources
+BUILT_SOURCES = $(MESA_UTIL_GENERATED_FILES)
+
+CLEANFILES = $(BUILT_SOURCES)
+
noinst_LTLIBRARIES = libmesautil.la
libmesautil_la_CPPFLAGS = \
@@ -30,7 +34,12 @@ libmesautil_la_CPPFLAGS = \
-I$(top_srcdir)/include \
$(VISIBILITY_CFLAGS)
-libmesautil_la_SOURCES = $(MESA_UTIL_FILES)
+libmesautil_la_SOURCES = \
+ $(MESA_UTIL_FILES) \
+ $(MESA_UTIL_GENERATED_FILES)
+
+format_srgb.c: $(srcdir)/format_srgb.py
+ $(AM_V_GEN) $(PYTHON2) $< > $@
### Tests: