summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorKenneth Graunke <kenneth@whitecape.org>2014-02-25 01:08:45 -0800
committerJason Ekstrand <jason.ekstrand@intel.com>2014-08-04 11:07:05 -0700
commit72e55bb6888ff4d6b69b10d9c58573e4c3d492ec (patch)
tree9084fd3c939f545bbc0d6a214564755bca9745cb /src/util/Makefile.am
parent1e0da6233be6e5fb0143615d5e3d3642ddb7964f (diff)
util: Move the open-addressing linear-probing hash_table to src/util.
This hash table is used in core Mesa, the GLSL compiler, and the i965 driver, which makes it a good candidate for the new src/util module. It's much faster than program/hash_table.[ch] (see commit 6991c2922f5 for data), and José's u_hash_table.c has a comment saying Gallium should probably consider switching to a linear probing hash table at some point. So this seems like the best candidate for a shared data structure. Signed-off-by: Kenneth Graunke <kenneth@whitecape.org> v2 (Jason Ekstrand): Pick up another hash_table use and patch up scons Signed-off-by: Jason Ekstrand <jason.ekstrand@intel.com> Reviewed-by: Marek Olšák <marek.olsak@amd.com>
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 1ed70c2c6ef..0f9dcab6a59 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -28,6 +28,7 @@ noinst_LTLIBRARIES = libmesautil.la
libmesautil_la_CPPFLAGS = \
$(DEFINES) \
-I$(top_srcdir)/include \
+ -I$(top_srcdir)/src/mapi \
-I$(top_srcdir)/src/mesa \
$(VISIBILITY_CFLAGS)