summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorKenneth Graunke <kenneth@whitecape.org>2014-02-24 23:39:14 -0800
committerJason Ekstrand <jason.ekstrand@intel.com>2014-08-04 11:06:58 -0700
commit1e0da6233be6e5fb0143615d5e3d3642ddb7964f (patch)
treeb33478332a051d4d587009cc8a76b71c5210bdc6 /src/util/Makefile.am
parentdcc29c18b4affd0a69202a822ffe77d94594f98b (diff)
util: Move ralloc to a new src/util directory.
For a long time, we've wanted a place to put utility code which isn't directly tied to Mesa or Gallium internals. This patch creates a new src/util directory for exactly that purpose, and builds the contents as libmesautil.la. ralloc seemed like a good first candidate. These days, it's directly used by mesa/main, i965, i915, and r300g, so keeping it in src/glsl didn't make much sense. Signed-off-by: Kenneth Graunke <kenneth@whitecape.org> v2 (Jason Ekstrand): More realloc uses and some scons fixes Signed-off-by: Jason Ekstrand <jason.ekstrand@intel.com> Reviewed-by: Marek Olšák <marek.olsak@amd.com>
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am53
1 files changed, 53 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
new file mode 100644
index 00000000000..1ed70c2c6ef
--- /dev/null
+++ b/src/util/Makefile.am
@@ -0,0 +1,53 @@
+# Copyright © 2014 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+# IN THE SOFTWARE.
+
+SUBDIRS = . tests
+
+include Makefile.sources
+
+noinst_LTLIBRARIES = libmesautil.la
+
+libmesautil_la_CPPFLAGS = \
+ $(DEFINES) \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src/mesa \
+ $(VISIBILITY_CFLAGS)
+
+libmesautil_la_SOURCES = $(MESA_UTIL_FILES)
+
+### Tests:
+
+CFLAGS_FOR_TESTS = $(PTHREAD_CFLAGS)
+CPPFLAGS_FOR_TESTS = \
+ $(libmesautil_la_CPPFLAGS) \
+ -I$(top_srcdir)/src/gtest/include
+LDADD_FOR_TESTS = \
+ $(top_builddir)/src/gtest/libgtest.la \
+ $(top_builddir)/src/util/libmesautil.la \
+ $(PTHREAD_LIBS)
+
+TESTS = tests/ralloc_test
+check_PROGRAMS = $(TESTS)
+
+tests_ralloc_test_SOURCES = tests/ralloc_test.cpp
+tests_ralloc_test_CFLAGS = $(CFLAGS_FOR_TESTS)
+tests_ralloc_test_CPPFLAGS = $(CPPFLAGS_FOR_TESTS)
+tests_ralloc_test_LDADD = $(LDADD_FOR_TESTS)