summaryrefslogtreecommitdiff
path: root/src/mesa/drivers/dri/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2013-09-27 16:57:11 -0700
committerEric Anholt <eric@anholt.net>2013-10-24 14:13:09 -0700
commitbdcee13ca374e4dd72c46951cb137b4f60a6303f (patch)
tree20b8b41ebd4e2b4ba82436c89f4f910bd41fffe7 /src/mesa/drivers/dri/Makefile.am
parent86d50c2f1567eebd193ac797a49c58c969646787 (diff)
swrast: Build the driver into the shared mesa_dri_drivers.so.
v2: drop dridir now that it's unused. v3: Fix linking after rebase when building just swrast from classic but a drm-using gallium driver. v4: Consistently put spaces around += in the updated Makefile.am block. v5: Set a global driverAPI variable so loaders don't have to update to createNewScreen2() (though they may want to for thread safety). Reviewed-by: Matt Turner <mattst88@gmail.com> (v3) Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com>
Diffstat (limited to 'src/mesa/drivers/dri/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/mesa/drivers/dri/Makefile.am b/src/mesa/drivers/dri/Makefile.am
index 57b2341fa07..aee6990c439 100644
--- a/src/mesa/drivers/dri/Makefile.am
+++ b/src/mesa/drivers/dri/Makefile.am
@@ -37,7 +37,9 @@ MEGADRIVERS += radeon_dri.so
endif
if HAVE_SWRAST_DRI
-SUBDIRS+=swrast
+SUBDIRS += swrast
+MEGADRIVERS_DEPS += swrast/libswrast_dri.la
+MEGADRIVERS += swrast_dri.so
endif
pkgconfigdir = $(libdir)/pkgconfig