summaryrefslogtreecommitdiff
path: root/src/mesa/drivers/dri/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2013-09-27 16:32:40 -0700
committerEric Anholt <eric@anholt.net>2013-10-24 14:13:09 -0700
commit86d50c2f1567eebd193ac797a49c58c969646787 (patch)
treeea4c6298494f67b5feeff2c32652c42689303753 /src/mesa/drivers/dri/Makefile.am
parent6665b71b22c265a318ff76178cc27732512791a8 (diff)
radeon: Build the driver into the shared mesa_dri_drivers.so.
This required some reordering of headers to ensure that the symbol name redefines happened before any prototypes. v2: drop dridir now that it's unused. v3: Consistently put spaces around += in the updated Makefile.am blocks. v4: Set a global driverAPI variable so loaders don't have to update to createNewScreen2() (though they may want to for thread safety). Reviewed-by: Matt Turner <mattst88@gmail.com> (v2) Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com>
Diffstat (limited to 'src/mesa/drivers/dri/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/mesa/drivers/dri/Makefile.am b/src/mesa/drivers/dri/Makefile.am
index 33268408668..57b2341fa07 100644
--- a/src/mesa/drivers/dri/Makefile.am
+++ b/src/mesa/drivers/dri/Makefile.am
@@ -25,11 +25,15 @@ MEGADRIVERS += nouveau_vieux_dri.so
endif
if HAVE_R200_DRI
-SUBDIRS+=r200
+SUBDIRS += r200
+MEGADRIVERS_DEPS += r200/libr200_dri.la
+MEGADRIVERS += r200_dri.so
endif
if HAVE_RADEON_DRI
-SUBDIRS+=radeon
+SUBDIRS += radeon
+MEGADRIVERS_DEPS += radeon/libradeon_dri.la
+MEGADRIVERS += radeon_dri.so
endif
if HAVE_SWRAST_DRI