summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2017-05-20 00:04:33 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2017-05-20 00:12:56 +0100
commit9a90d6a9d4ee1632aa357a2ac9be150e058e2c10 (patch)
tree84d96bf3abf0c9591d8ce54f9b26c973b76d0286 /configure.ac
parent5233eaf9ee85bb551ea38c1e2bbd8ac167754e50 (diff)
configure.ac: add xcb-fixes to the XCB DRI3 list
The XCB module is used by the VL targets. Thus omitting it can lead to link-time errors due to unresolved symbols. Other DRI3 users such as the Vulkan WSI and the dri3 loader helper do not use an update region in their xcb_present_pixmap() call. We will look into that at a later stage. Fixes: acf3d2afab0 ("configure: check once for DRI3 dependencies") Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=101110 Signed-off-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a6ea8b42da1..b788137d515 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1723,7 +1723,7 @@ fi
if test x"$enable_dri3" = xyes; then
DEFINES="$DEFINES -DHAVE_DRI3"
- dri3_modules="x11-xcb xcb >= $XCB_REQUIRED xcb-dri3 xcb-present xcb-sync xshmfence >= $XSHMFENCE_REQUIRED"
+ dri3_modules="x11-xcb xcb >= $XCB_REQUIRED xcb-dri3 xcb-fixes xcb-present xcb-sync xshmfence >= $XSHMFENCE_REQUIRED"
PKG_CHECK_MODULES([XCB_DRI3], [$dri3_modules])
fi