summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2017-05-18 21:27:01 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2017-05-20 00:12:56 +0100
commit5233eaf9ee85bb551ea38c1e2bbd8ac167754e50 (patch)
tree23efdea2cad0a99b00236189dce5b1fa96e6ecf0 /configure.ac
parent80e643345ed0d8d3263b4ee23dd2998f0da170a8 (diff)
automake: add SWR LLVM gen_builder.hpp workaround
As gen_builder.hpp file is generated, it contains information that is specific to the LLVM version it originates from. As suggested by Tim, the file seems to be forwards compatible. So in order to produce ship a file which will work everywhere we should be using earlies supported LLVM - 3.9. With this we're back on track and can build all of mesa without python/mako/flex and friends. In the long term we might want to see if the python generators can be updated to produce LLVM version agnostic files. At least within the range supported by SWR. Cc: <mesa-stable@lists.freedesktop.org> Cc: Chuck Atkins <chuck.atkins@kitware.com> Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Tim Rowley <timothy.o.rowley@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a336b5259ed..a6ea8b42da1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2517,6 +2517,10 @@ if test -n "$with_gallium_drivers"; then
done
fi
+# XXX: Keep in sync with LLVM_REQUIRED_SWR
+AM_CONDITIONAL(SWR_INVALID_LLVM_VERSION, test "x$LLVM_VERSION" != x3.9.0 -a \
+ "x$LLVM_VERSION" != x3.9.1)
+
if test "x$enable_llvm" = "xyes" -a "$with_gallium_drivers"; then
llvm_require_version $LLVM_REQUIRED_GALLIUM "gallium"
llvm_add_default_components "gallium"