summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2017-12-08 11:08:29 +0100
committerThomas Haller <thaller@redhat.com>2017-12-08 11:09:34 +0100
commit79d5a06c8b307c56e663dc9ed914b34e860cd2bf (patch)
tree09c775e2292aab5dcc00910c5d66d9c05c970e6a /configure.ac
parentb1c65d32fe40cc26113e7848da6f764224fab21b (diff)
build: don't link libnm against libjansson when building --without-json-validation
Also, don't add the CFLAGS for libjansson to dflt_cppflags_libnm_core. dflt_cppflags_libnm_core is used also by core and libnm. But those components do not (directly) link against libjansson. The cannot use these flags.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c358d48821..0f3933eaed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -688,6 +688,7 @@ else
fi
AC_DEFINE(WITH_JSON_VALIDATION, 1, [Define if JSON validation in libnm is enabled])
fi
+AM_CONDITIONAL(WITH_JSON_VALIDATION, test "${enable_json_validation}" != "no")
# we usually compile with polkit support. --enable-polkit=yes|no only sets the
# default configuration for main.auth-polkit. User can always enable/disable polkit