summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2017-12-08 08:56:46 +0100
committerThomas Haller <thaller@redhat.com>2017-12-08 09:07:30 +0100
commitb1c65d32fe40cc26113e7848da6f764224fab21b (patch)
treeab1defa0e16279e33f6bd176813cd8cf4a352fa7 /configure.ac
parentaf6f62be8d0e154ff9936310653e5dfc7074771a (diff)
Revert "Makefile: rework team compilation flags"
I don't think we should do this. - renamining/dropping configure options is still an annoyance, because it requires to different ./configure options depending on the version. The rename from --enable-teamctl to --enable-team might be theoretically nice, but more annoying then helpful. - There is no strict dependency between --enable-team and --enable-json-validation. At most, one could argue that when enabling the team plugin (--enable-teamctl), then libnm must also be build with --enable-json-validation. But in fact, the team plugin will happily work with a libnm that doesn't link against libjansson. That is --enable-teamctl --disable-json-validation will work in practice just fine. On the other hand, libnm is a client library to create connection profiles, fully supporting team profiles also makes sense if the actual plugin is not installed (or build). Thus, --disable-teamctl --enable-json-validation certainly makes sense. At this point, one might ask whether libnm is even still complete without libjansson. Maybe libnm should *require* --enable-json-validation. But that is not what the patch was doing, and it would also need some careful consideration before doing so. This reverts commit 9d5cd7eae8edc8c558d26f04ffd163effafe57f9.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 23 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 8a849d3f0a..c358d48821 100644
--- a/configure.ac
+++ b/configure.ac
@@ -657,10 +657,10 @@ else
have_team_prereq=no
fi
-AC_ARG_ENABLE(team,
- AS_HELP_STRING([--enable-team], [enable Teamd control support]),
- [enable_team=${enableval}], [enable_team=${have_team_prereq}])
-if (test "${enable_team}" = "yes"); then
+AC_ARG_ENABLE(teamdctl,
+ AS_HELP_STRING([--enable-teamdctl], [enable Teamd control support]),
+ [enable_teamdctl=${enableval}], [enable_teamdctl=${have_team_prereq}])
+if (test "${enable_teamdctl}" = "yes"); then
if test "$have_teamdctl" = "no"; then
AC_MSG_ERROR(Libteamdctl is required for team support)
fi
@@ -669,11 +669,25 @@ if (test "${enable_team}" = "yes"); then
fi
# temporary bug workaround
LIBTEAMDCTL_CFLAGS=`echo $LIBTEAMDCTL_CFLAGS | sed -e 's:/teamdctl.h::'`
- AC_DEFINE(WITH_TEAM, 1, [Define if you have Teamd control support])
+ AC_DEFINE(WITH_TEAMDCTL, 1, [Define if you have Teamd control support])
else
- AC_DEFINE(WITH_TEAM, 0, [Define if you have Teamd control support])
+ AC_DEFINE(WITH_TEAMDCTL, 0, [Define if you have Teamd control support])
+fi
+AM_CONDITIONAL(WITH_TEAMDCTL, test "${enable_teamdctl}" = "yes")
+
+# Jansson for team configuration validation
+AC_ARG_ENABLE(json-validation,
+ AS_HELP_STRING([--enable-json-validation], [Enable JSON validation in libnm]),
+ [enable_json_validation=${enableval}],
+ [enable_json_validation=${have_jansson}])
+if (test "${enable_json_validation}" == "no"); then
+ AC_DEFINE(WITH_JSON_VALIDATION, 0, [Define if JSON validation in libnm is enabled])
+else
+ if test "$have_jansson" = "no"; then
+ AC_MSG_ERROR([jansson is needed for team configuration validation. Use --disable-json-validation to build without it.])
+ fi
+ AC_DEFINE(WITH_JSON_VALIDATION, 1, [Define if JSON validation in libnm is enabled])
fi
-AM_CONDITIONAL(WITH_TEAM, test "${enable_team}" = "yes")
# we usually compile with polkit support. --enable-polkit=yes|no only sets the
# default configuration for main.auth-polkit. User can always enable/disable polkit
@@ -1397,7 +1411,7 @@ echo " ppp: $enable_ppp ${PPPD_PLUGIN_DIR}"
echo " modemmanager-1: $with_modem_manager_1"
echo " ofono: $with_ofono"
echo " concheck: $enable_concheck"
-echo " team: $enable_team"
+echo " libteamdctl: $enable_teamdctl"
echo " ovs: $enable_ovs"
echo " libnm-glib: $with_libnm_glib"
echo " nmcli: $build_nmcli"
@@ -1436,6 +1450,7 @@ echo " valgrind: $with_valgrind $with_valgrind_suppressions"
echo " code coverage: $enable_code_coverage"
echo " LTO: $enable_lto"
echo " linker garbage collection: $enable_ld_gc"
+echo " JSON validation for libnm: $enable_json_validation"
echo " sanitizers: $sanitizers"
echo " Mozilla Public Suffix List: $with_libpsl"
echo