summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorRobert Foss <robert.foss@collabora.com>2016-07-27 13:17:39 -0400
committerDaniel Vetter <daniel.vetter@ffwll.ch>2016-08-04 13:13:05 +0200
commitf984bc7de204aa029a59e89faa90b32b3fc6d5e1 (patch)
tree0dd17df9e413b0984bd15d528a19dc49ed201732 /tools/Makefile.am
parentf6b9f961aaca1a255e833564a7d50a079d9e51b2 (diff)
tools/Makefile: Don't build tools that depend on libdrm_intel
Use the HAS_INTEL automake flag to avoid building tools that won't compile unless libdrm_intel is available in the build system. Signed-off-by: Robert Foss <robert.foss@collabora.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 5f4514436..f8ac0d8ba 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,5 +1,10 @@
include Makefile.sources
+if HAVE_LIBDRM_INTEL
+ bin_PROGRAMS += $(LIBDRM_INTEL_BIN)
+ intel_error_decode_LDFLAGS = -lz
+endif
+
SUBDIRS = null_state_gen registers
AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/lib