summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorOscar Mateo <oscar.mateo@intel.com>2013-11-12 11:50:35 +0000
committerDaniel Vetter <daniel.vetter@ffwll.ch>2013-11-12 12:00:36 +0100
commitea11d103e0617e33bce6f11328521d15b13422b0 (patch)
treea62d0dc2e65e1e76478250d09f065a32e288ebd6 /tools/Makefile.am
parentc50dd7c149a64b683977d14bc59262f70dda15fa (diff)
build: list all test/tool/lib source files in their own Makefile.sources
In this way, all source files are listed in Makefile.sources and included from Makefile.am, thus enabling the reuse from Android makefiles. Signed-off-by: Oscar Mateo <oscar.mateo@intel.com> Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am54
1 files changed, 2 insertions, 52 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index d4303775e..151092bcf 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,60 +1,10 @@
+include Makefile.sources
+
if HAVE_DUMPER
SUBDIRS = quick_dump
endif
-bin_PROGRAMS = \
- intel_disable_clock_gating \
- intel_audio_dump \
- intel_backlight \
- intel_bios_dumper \
- intel_bios_reader \
- intel_error_decode \
- intel_framebuffer_dump \
- intel_gpu_top \
- intel_gpu_time \
- intel_gtt \
- intel_opregion_decode \
- intel_perf_counters \
- intel_stepping \
- intel_reg_checker \
- intel_reg_dumper \
- intel_reg_snapshot \
- intel_reg_write \
- intel_reg_read \
- intel_forcewaked \
- intel_dpio_read \
- intel_dpio_write \
- intel_l3_parity \
- intel_punit_read \
- intel_punit_write \
- intel_nc_write \
- intel_nc_read \
- intel_vga_read \
- intel_vga_write
-
-noinst_PROGRAMS = \
- intel_dump_decode \
- intel_infoframes \
- intel_lid \
- intel_panel_fitter
-
-dist_bin_SCRIPTS = intel_gpu_abrt
-
AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/lib
AM_CFLAGS = $(DRM_CFLAGS) $(PCIACCESS_CFLAGS) $(CWARNFLAGS) $(CAIRO_CFLAGS)
LDADD = $(top_builddir)/lib/libintel_tools.la $(DRM_LIBS) $(PCIACCESS_LIBS) $(CAIRO_LIBS) $(LIBUDEV_LIBS)
-intel_dump_decode_SOURCES = \
- intel_dump_decode.c
-
-intel_error_decode_SOURCES = \
- intel_error_decode.c
-
-intel_bios_reader_SOURCES = \
- intel_bios_reader.c \
- intel_bios.h
-
-intel_l3_parity_SOURCES = \
- intel_l3_parity.c \
- intel_l3_parity.h \
- intel_l3_udev_listener.c