summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2015-11-13 16:45:13 -0800
committerThomas Wood <thomas.wood@intel.com>2015-11-24 16:36:54 +0000
commitb088e305750c9df7b5d3a16f01fd2a7dba22177f (patch)
tree903d86f071455c5041551c37fdfcff166467b8ad /tools/Makefile.am
parentdcdf21beb8fb40c4061e7dbcf0a021c6513d5090 (diff)
tools/aubdump: Link with -ldl.
aubdump.c uses dlsym(), so it needs to link with -ldl. Otherwise: /bin/sh: symbol lookup error: /usr/lib64/intel_aubdump.so: undefined symbol: dlsym Signed-off-by: Matt Turner <mattst88@gmail.com> Signed-off-by: Thomas Wood <thomas.wood@intel.com>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 8e454b4f7..90a8ec1bb 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -14,7 +14,7 @@ module_LTLIBRARIES = intel_aubdump.la
moduledir = $(libdir)
intel_aubdump_la_LDFLAGS = -module -avoid-version -no-undefined
intel_aubdump_la_SOURCES = aubdump.c intel_aub.h
-intel_aubdump_la_LIBADD = $(top_builddir)/lib/libintel_tools.la
+intel_aubdump_la_LIBADD = $(top_builddir)/lib/libintel_tools.la -ldl
bin_SCRIPTS = intel_aubdump
CLEANFILES = $(bin_SCRIPTS)