summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authormarius vlad <marius.c.vlad@intel.com>2016-05-10 17:32:15 +0300
committerMarius Vlad <marius.c.vlad@intel.com>2016-05-11 18:22:05 +0300
commit701d8fdb363443453c4b613e9180f75ad36a7321 (patch)
tree200be95af16c037a99807fadcd764f736db482c1 /tools/Makefile.am
parent2d432fc5773df17f04283f4780dab161dd2e1c85 (diff)
benchmarks/, overlay/, demos/, tools/, tests/: Add optional Werror.
v2: Initially added Werror by default. Make it optional so it doesn't break android build and (potential) distros maintaing the package (Hinted by Damien Lespiau). --enable-werror will enable -Werror compiler flag. Signed-off-by: Marius Vlad <marius.c.vlad@intel.com> Acked-by: Damien Lespiau <damien.lespiau@intel.com>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index df48d94af..5f4514436 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -3,7 +3,9 @@ include Makefile.sources
SUBDIRS = null_state_gen registers
AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/lib
-AM_CFLAGS = $(DEBUG_CFLAGS) $(DRM_CFLAGS) $(PCIACCESS_CFLAGS) $(CWARNFLAGS) $(CAIRO_CFLAGS) $(LIBUNWIND_CFLAGS) -DPKGDATADIR=\"$(pkgdatadir)\"
+AM_CFLAGS = $(DEBUG_CFLAGS) $(DRM_CFLAGS) $(PCIACCESS_CFLAGS) $(CWARNFLAGS) \
+ $(CAIRO_CFLAGS) $(LIBUNWIND_CFLAGS) -DPKGDATADIR=\"$(pkgdatadir)\" \
+ $(WERROR_CFLAGS)
LDADD = $(top_builddir)/lib/libintel_tools.la
AM_LDFLAGS = -Wl,--as-needed