summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorDaniel Vetter <daniel.vetter@ffwll.ch>2017-09-05 18:19:45 +0200
committerDaniel Vetter <daniel.vetter@ffwll.ch>2017-09-08 17:02:38 +0200
commit692357e240c6cbcd9bef62554c8b09bd2f5ed839 (patch)
tree50511d0c383ed827b1262c007658db7c403f2467 /tools/Makefile.am
parent80447fec4ac419efe1e51ebcccc00bebcc5f9874 (diff)
build: Define _GNU_SOURCE in Makefile.am
In meson I want to just set this everywhere (no reason not to), and doing so will allow us to clean up a few things. But that means autofoo needs to follow suit. v2: Rebase. Reviewed-by: Eric Anholt <eric@anholt.net> Acked-by: Jani Nikula <jani.nikula@intel.com> Acked-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Acked-by: Petri Latvala <petri.latvala@intel.com> Acked-by: Daniel Stone <daniels@collabora.com> Acked-by: Radoslaw Szwichtenberg <radoslaw.szwichtenberg@intel.com> Signed-off-by: Daniel Vetter <daniel.vetter@intel.com>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index c40e75c73..2c7b57997 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -18,7 +18,7 @@ SUBDIRS = null_state_gen registers
AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/lib
AM_CFLAGS = $(DEBUG_CFLAGS) $(DRM_CFLAGS) $(PCIACCESS_CFLAGS) $(CWARNFLAGS) \
$(CAIRO_CFLAGS) $(LIBUNWIND_CFLAGS) -DPKGDATADIR=\"$(pkgdatadir)\" \
- $(WERROR_CFLAGS)
+ $(WERROR_CFLAGS) -D_GNU_SOURCE
LDADD = $(top_builddir)/lib/libintel_tools.la
AM_LDFLAGS = -Wl,--as-needed