summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorThomas Wood <thomas.wood@intel.com>2015-08-27 14:34:08 +0100
committerThomas Wood <thomas.wood@intel.com>2015-09-08 16:14:45 +0100
commit4ee6709e3bd98eb52f4c4c22f58fecf9750f26eb (patch)
treef3320f29cc2ab05801ffc611010271ca8941ac8d /tools/Makefile.am
parent88cbb41ade5a66f96b7cd3844ce86f43d192afa0 (diff)
tests/tools: add --as-needed to linker flags
Add --as-needed to the linker flags to reduce the number of shared library dependencies, since not all the tests and tools use all the libraries required by the helper library (for example, many tests do not use cairo). This helps portability of the binaries and also makes a very small improvement to the execution speed and memory consumption. Signed-off-by: Thomas Wood <thomas.wood@intel.com>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 95f13f902..0aeb1739e 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -9,6 +9,7 @@ endif
AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/lib
AM_CFLAGS = $(DEBUG_CFLAGS) $(DRM_CFLAGS) $(PCIACCESS_CFLAGS) $(CWARNFLAGS) $(CAIRO_CFLAGS) $(LIBUNWIND_CFLAGS)
LDADD = $(top_builddir)/lib/libintel_tools.la $(DRM_LIBS) $(PCIACCESS_LIBS) $(CAIRO_LIBS) $(LIBUDEV_LIBS) $(LIBUNWIND_LIBS) -lm
+AM_LDFLAGS = -Wl,--as-needed
# aubdumper