summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHib Eris <hib@hiberis.nl>2011-11-03 13:25:15 +0100
committerBastien Nocera <hadess@hadess.net>2012-02-01 15:53:20 +0000
commitde0bb427127947c23c674e12eeac179996482185 (patch)
treed46c6f608749207b967ef2dae574c9d665e0583f /Makefile.am
parent1f3c3f46e36c4d90ba6fbccc9b44f2e2814759d4 (diff)
Disable checks when cross compiling
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 16dcf8b..6467de4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,6 +79,9 @@ create-pot:
$(AM_V_GEN) $(MAKE) -C po shared-mime-info.pot
check: create-pot freedesktop.org.xml update-mime-database$(EXEEXT) check-translations
+if CROSS_COMPILING
+ @echo "Cross compiling: Skipping checks"
+else
if test -e $(top_builddir)/freedesktop.org.xml; then \
xmllint --noout --valid $(top_builddir)/freedesktop.org.xml || exit 1; \
else \
@@ -103,6 +106,7 @@ check: create-pot freedesktop.org.xml update-mime-database$(EXEEXT) check-transl
fi
@echo Number of mime-types that might need generic-icon: `grep "mime-type type=" $(srcdir)/freedesktop.org.xml.in | grep -v video/ | grep -v image/ | grep -v text/ | grep -v audio/ | grep -v "octet-stream" | wc -l` ; \
echo Number of mime-types with a generic icon: `grep "generic-icon name=" $(srcdir)/freedesktop.org.xml.in | wc -l` ;
+endif
check-translations:
@for i in $(top_srcdir)/po/*.po ; do \