summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2008-04-10 10:18:18 +0000
committerBastien Nocera <hadess@hadess.net>2008-04-10 10:18:18 +0000
commit6e59c2af44970542aae3e6266e50696f7e5ba88a (patch)
treeca930ab079c1728b8e7e628b205064e0bb6e22a8 /Makefile.am
parent7139b5c4cd4bf586c4521deaa1e161d57305075a (diff)
2008-04-10 Bastien Nocera <hadess@hadess.net>
* Makefile.am: error out when one of the tests fails * freedesktop.org.xml.in: Fix matchlet for application/x-java, patch by David Faure <faure@kde.org> (Closes: #10334) * tests/helloworld.java (helloworld), (helloworld.main): * tests/list: * tests/test.class: Add test case for Class and Java source files
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 4b6464d..4e68e2d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -59,18 +59,20 @@ uninstall-hook:
all: check
check:
- if test -n $(XMLLINT) ; then \
+ @if test -n $(XMLLINT) ; then \
xmllint --noout --valid $(srcdir)/freedesktop.org.xml; \
fi
- if test -d CVS/ && test -x ../xdgmime/src/test-mime-data ; then \
+ @if test -d CVS/ && test -x ../xdgmime/src/test-mime-data ; then \
mkdir -p $(builddir)/temp-mime-dir/mime/packages ; \
cp -a $(builddir)/freedesktop.org.xml $(builddir)/temp-mime-dir/mime/packages/ ; \
XDG_DATA_DIRS="$(builddir)/temp-mime-dir/" $(builddir)/update-mime-database "$(builddir)/temp-mime-dir/mime/" ; \
- XDG_DATA_DIRS="$(builddir)/temp-mime-dir/" ../xdgmime/src/test-mime-data -v tests/list; \
+ XDG_DATA_DIRS="$(builddir)/temp-mime-dir/" ../xdgmime/src/test-mime-data -v tests/list || exit 1; \
rm -rf "$(builddir)/temp-mime-dir/" ; \
fi
- if `grep comment $(srcdir)/freedesktop.org.xml.in | grep -v _comment | grep -q -v '<!'` ; then \
- echo "Some comments are not marked as translatable, fix before committing" ; \
+ @if `grep comment $(srcdir)/freedesktop.org.xml.in | grep -v _comment | grep -q -v '<!'` ; then \
+ echo "***************************************************************************" ; \
+ echo "*** Some comments are not marked as translatable, fix before committing ***" ; \
+ echo "***************************************************************************" ; \
exit 1 ; \
fi