summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2009-10-14 13:18:12 +0100
committerBastien Nocera <hadess@hadess.net>2009-10-14 13:18:12 +0100
commit3d1e26a9a7705586c7cd9d5764b2e0f51f01da6f (patch)
treebd1fb328a39fe1795ea74fe9e3240b51b88a9060 /Makefile.am
parentf2201ab17100546cb60e2fc1409aec00c29d1304 (diff)
Generate changelog from git history
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 718567a..b143ac3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -99,3 +99,13 @@ check-translations:
fi; \
done;
+# Build ChangeLog from GIT history
+ChangeLog:
+ @if test -f $(top_srcdir)/.git/HEAD; then \
+ git log --stat --after="Tue Oct 6 14:46:33 2009 +0000" > $@; \
+ fi
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
+