summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2011-06-20 10:54:58 +0100
committerBastien Nocera <hadess@hadess.net>2011-06-20 10:55:32 +0100
commit3c853731949066cfd3dcbf3a37314cefb6476a6a (patch)
treecd41a29241a5a7594a42f47bdf57284f1b319e94 /Makefile.am
parent1b26e8117d21bde4da4a05b81797fecfc656cf93 (diff)
build: Error out on invalid XML
So that it's clear that the xml DTD checking failed.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 65986e8..a46a88c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,9 +75,9 @@ create-pot:
check: create-pot freedesktop.org.xml update-mime-database check-translations
if test -e $(top_builddir)/freedesktop.org.xml; then \
- xmllint --noout --valid $(top_builddir)/freedesktop.org.xml; \
+ xmllint --noout --valid $(top_builddir)/freedesktop.org.xml || exit 1; \
else \
- xmllint --noout --valid $(top_srcdir)/freedesktop.org.xml; \
+ xmllint --noout --valid $(top_srcdir)/freedesktop.org.xml || exit 1; \
fi; \
if test -d .git/ && test -x $(top_builddir)/update-mime-database && test -d $(top_srcdir)/mime-db-tests ; then \
$(top_builddir)/update-mime-database mime-db-tests/ ; \