summaryrefslogtreecommitdiff
path: root/src/linux/Makefile.am
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2011-04-26 14:31:00 +0200
committerMartin Pitt <martin.pitt@ubuntu.com>2011-04-26 14:31:00 +0200
commit5c37df249bc9677b618e4409d1a4d618ff06898a (patch)
treea1b2aa031a80dfd5a7b1cd5a6d15dd298b8a0191 /src/linux/Makefile.am
parent37fdb2c9595922692e43c84c513f161970bcd02f (diff)
trivial: Fix Linux integration test dependency on upowerd
With nested Makefiles we can't depend on a generated file in a different directory (breaks "make clean && make check"). Thus move the call of the Linux integration test suite into src/Makefile.am, and only run it if we build the Linux backend.
Diffstat (limited to 'src/linux/Makefile.am')
-rw-r--r--src/linux/Makefile.am7
1 files changed, 0 insertions, 7 deletions
diff --git a/src/linux/Makefile.am b/src/linux/Makefile.am
index a2a5e8f..e2dcd85 100644
--- a/src/linux/Makefile.am
+++ b/src/linux/Makefile.am
@@ -50,13 +50,6 @@ EXTRA_DIST = $(libupshared_la_SOURCES) \
libupshared_la_CFLAGS = \
$(WARNINGFLAGS_C)
-if UP_BUILD_TESTS
-DBUS_LAUNCH=$(shell which dbus-launch)
-
-check-local: $(top_builddir)/src/upowerd
- env top_builddir=$(top_builddir) $(DBUS_LAUNCH) $(srcdir)/integration-test -v
-endif
-
clean-local :
rm -f *~