summaryrefslogtreecommitdiff
path: root/src/linux/Makefile.am
diff options
context:
space:
mode:
authorChristian Kellner <christian@kellner.me>2017-02-17 13:56:21 +0100
committerBastien Nocera <hadess@hadess.net>2017-03-25 18:07:02 +0100
commit09cdb0ccfc8b8714a4a27004485e2ea4a196e23e (patch)
treea3e23f43e75109630cab6ef6984e05ebb94b616d /src/linux/Makefile.am
parent01cd65c1a7c88cf66e36b8da2d9cca2d0f23050d (diff)
linux: Use inhibitor lock to guard poll pausing
Use an inhibitor lock obtained via logind to make sure the polling is paused before the system is put to sleep, rather than racing with the suspension. https://bugs.freedesktop.org/show_bug.cgi?id=99763
Diffstat (limited to 'src/linux/Makefile.am')
-rw-r--r--src/linux/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/linux/Makefile.am b/src/linux/Makefile.am
index e92bdd5..139fdad 100644
--- a/src/linux/Makefile.am
+++ b/src/linux/Makefile.am
@@ -9,6 +9,7 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/libupower-glib \
$(USB_CFLAGS) \
$(GIO_CFLAGS) \
+ $(GIO_UNIX_CFLAGS) \
$(GUDEV_CFLAGS) \
$(POLKIT_CFLAGS) \
$(GLIB_CFLAGS) \
@@ -56,7 +57,9 @@ hidpp_test_SOURCES = \
hidpp_test_LDADD = \
-lm \
$(GLIB_LIBS) \
- $(GIO_LIBS)
+ $(GIO_LIBS) \
+ $(GIO_UNIX_LIBS)
+
hidpp_test_CFLAGS = $(AM_CFLAGS) $(WARNINGFLAGS_C)
EXTRA_DIST = $(libupshared_la_SOURCES) \