summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEric Koegel <eric.koegel@gmail.com>2015-07-06 20:25:30 +0300
committerBastien Nocera <hadess@hadess.net>2015-07-07 17:10:38 +0200
commit77239cc4470fc515e1c8c6c21005fa08f3b1b04e (patch)
tree5585e1e59f421b227cad2c367b0e397913c64735 /src/Makefile.am
parentc9b2e177267b623850b3deedb1242de7d2e413ee (diff)
bsd: Add critical action support for *BSD
This patch adds support for using ConsoleKit2's DBUS API to implement the critical action for FreeBSD and OpenBSD. It does so by creating a common backend file both can use to implement the API calls. https://bugs.freedesktop.org/show_bug.cgi?id=85242
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 784a3c8..314d227 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,16 @@
## Process this file with automake to produce Makefile.in
+DIST_SUBDIRS = dummy freebsd linux openbsd bsd
SUBDIRS = dummy freebsd linux openbsd
+if BACKEND_TYPE_FREEBSD
+SUBDIRS += bsd
+endif
+
+if BACKEND_TYPE_OPENBSD
+SUBDIRS += bsd
+endif
+
AM_CPPFLAGS = \
$(PIE_CFLAGS) \
-I$(top_builddir)/src -I$(top_srcdir)/src \
@@ -78,6 +87,7 @@ upowerd_SOURCES = \
up-backend.h \
up-native.h \
up-main.c \
+ up-backend-bsd-private.h \
$(BUILT_SOURCES)
upowerd_CPPFLAGS = \
@@ -98,12 +108,14 @@ endif
if BACKEND_TYPE_FREEBSD
upowerd_LDADD += \
- freebsd/libupshared.la
+ freebsd/libupshared.la \
+ bsd/libupsharedcommon.la
endif
if BACKEND_TYPE_OPENBSD
upowerd_LDADD += \
- openbsd/libupshared.la
+ openbsd/libupshared.la \
+ bsd/libupsharedcommon.la
endif
if BACKEND_TYPE_LINUX