summaryrefslogtreecommitdiff
path: root/libdevkit-power/Makefile.am
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2008-08-11 10:40:22 +0100
committerRichard Hughes <richard@hughsie.com>2008-08-11 10:40:22 +0100
commit32aaf9ed9318d21f4073fafc12202a872611a9ee (patch)
tree67dad7b40929db575b10cdd20ac85c3527617ec9 /libdevkit-power/Makefile.am
parentf8a902dff94fd0e0fec82803bba9344bff39816e (diff)
move DkpClient and DkpClientDevice to libdevkit-power
Diffstat (limited to 'libdevkit-power/Makefile.am')
-rw-r--r--libdevkit-power/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/libdevkit-power/Makefile.am b/libdevkit-power/Makefile.am
index 30bb5dd..ea8c61b 100644
--- a/libdevkit-power/Makefile.am
+++ b/libdevkit-power/Makefile.am
@@ -1,6 +1,6 @@
INCLUDES = \
$(GLIB_CFLAGS) \
- $(DBUS_CFLAGS) \
+ $(DBUS_GLIB_CFLAGS) \
-I$(top_srcdir)/libdevkit-power \
-DPACKAGE_DATA_DIR=\""$(datadir)"\" \
-DPACKAGE_LOCALE_DIR=\""$(prefix)/$(DATADIRNAME)/locale"\"
@@ -11,6 +11,10 @@ noinst_LTLIBRARIES = \
libdevkit_power_la_SOURCES = \
dkp-debug.c \
dkp-debug.h \
+ dkp-client.c \
+ dkp-client.h \
+ dkp-client-device.c \
+ dkp-client-device.h \
dkp-history-obj.h \
dkp-history-obj.c \
dkp-enum.c \
@@ -18,7 +22,8 @@ libdevkit_power_la_SOURCES = \
dkp-object.c \
dkp-object.h
-libdevkit_power_la_LIBADD = $(INTLLIBS) $(GLIB_LIBS)
+libdevkit_power_la_LIBADD = $(INTLLIBS) $(GLIB_LIBS) $(DBUS_GLIB_LIBS)
+
clean-local:
rm -f *~