summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2018-03-26 17:15:50 +0300
committerArun Raghavan <arun@arunraghavan.net>2018-06-21 06:24:36 +0530
commit3b1093c0ad882640ef7cf2b88088d77988be7610 (patch)
treeeb1a06dd2cb92e6c92649ebddfd9e68006dbea29 /src/Makefile.am
parentfb600395e1e13ef68e36153faf02bda287927ae2 (diff)
bluetooth: Remove BlueZ 4 support
BlueZ 4 is no longer supported by BlueZ community for a long long time, also by moving to BlueZ 5 it should make it even more clearer that BlueZ 4 is no longer an option.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am26
1 files changed, 0 insertions, 26 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6fbd70501..eb711f278 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1462,13 +1462,6 @@ modlibexec_LTLIBRARIES += \
module-bluetooth-policy.la
endif
-if HAVE_BLUEZ_4
-modlibexec_LTLIBRARIES += \
- libbluez4-util.la \
- module-bluez4-discover.la \
- module-bluez4-device.la
-endif
-
if HAVE_BLUEZ_5
modlibexec_LTLIBRARIES += \
libbluez5-util.la \
@@ -2118,25 +2111,6 @@ module_bluetooth_discover_la_LDFLAGS = $(MODULE_LDFLAGS)
module_bluetooth_discover_la_LIBADD = $(MODULE_LIBADD)
module_bluetooth_discover_la_CFLAGS = $(AM_CFLAGS) -DPA_MODULE_NAME=module_bluetooth_discover
-# Bluetooth BlueZ 4 sink / source
-module_bluez4_discover_la_SOURCES = modules/bluetooth/module-bluez4-discover.c
-module_bluez4_discover_la_LDFLAGS = $(MODULE_LDFLAGS)
-module_bluez4_discover_la_LIBADD = $(MODULE_LIBADD) $(DBUS_LIBS) libbluez4-util.la
-module_bluez4_discover_la_CFLAGS = $(AM_CFLAGS) $(DBUS_CFLAGS) -DPA_MODULE_NAME=module_bluez4_discover
-
-libbluez4_util_la_SOURCES = \
- modules/bluetooth/a2dp-codecs.h \
- modules/bluetooth/bluez4-util.c \
- modules/bluetooth/bluez4-util.h
-libbluez4_util_la_LDFLAGS = -avoid-version
-libbluez4_util_la_LIBADD = $(MODULE_LIBADD) $(DBUS_LIBS)
-libbluez4_util_la_CFLAGS = $(AM_CFLAGS) $(DBUS_CFLAGS)
-
-module_bluez4_device_la_SOURCES = modules/bluetooth/module-bluez4-device.c modules/bluetooth/rtp.h
-module_bluez4_device_la_LDFLAGS = $(MODULE_LDFLAGS)
-module_bluez4_device_la_LIBADD = $(MODULE_LIBADD) $(DBUS_LIBS) $(SBC_LIBS) libbluez4-util.la
-module_bluez4_device_la_CFLAGS = $(AM_CFLAGS) $(DBUS_CFLAGS) $(SBC_CFLAGS) -DPA_MODULE_NAME=module_bluez4_device
-
# Bluetooth BlueZ 5 sink / source
libbluez5_util_la_SOURCES = \
modules/bluetooth/bluez5-util.c \