summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTanu Kaskinen <tanuk@iki.fi>2012-10-06 15:05:08 +0300
committerColin Guthrie <colin@mageia.org>2012-11-04 10:07:31 +0100
commit3e5b872dc2f8372824dc21324152d257b990d9f8 (patch)
treef6f579a54f91e9b9ed9674f14e9c57d2bbfa8c50 /Makefile.am
parent3b67ebb63e7920854ef9a972b47dcc2266cacab6 (diff)
build: Add .gitignore files to EXTRA_DIST.
As a packager, I want to be able to do "git format-patch v3.0..origin/master" and I want the generated patches to apply cleanly against the 3.0 tarball. The patches don't currently apply cleanly if there are any changes to the .gitignore files, because the .gitignore files are not shipped in the tarball. This patch fixes that problem.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8a94a7c96..e4bfbe55e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,7 +31,15 @@ EXTRA_DIST = \
vala/libpulse.deps \
vala/libpulse.vapi \
vala/libpulse-mainloop-glib.deps \
- vala/libpulse-mainloop-glib.vapi
+ vala/libpulse-mainloop-glib.vapi \
+ .gitignore \
+ doxygen/.gitignore \
+ m4/.gitignore \
+ man/.gitignore \
+ po/.gitignore \
+ src/.gitignore \
+ src/daemon/.gitignore \
+ src/pulse/.gitignore
SUBDIRS = src doxygen man po