summaryrefslogtreecommitdiff
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2011-09-25 12:21:02 +0200
committerCarlos Garcia Campos <carlosgc@gnome.org>2011-09-25 12:21:02 +0200
commitbba57e588fd1ee3a61f18405d1d1bf89fceb5b96 (patch)
tree1d5e8ac050be0b147feb0d00d58fc3be0ddca234 /utils/Makefile.am
parentf62c2f002c782d3a7887525f031d266aca6eb582 (diff)
xpdf303: Added the pdfdetach tool
I haven't merged xpdf code for embedded files, I think our implementation is better and more complete. I've adapated pdfdetach code to use our code and return also embedded files of file attachment annotations to match what xpdf does.
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index ac2a15e8..3a0c7426 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -44,6 +44,7 @@ endif
AM_LDFLAGS = @auto_import_flags@
bin_PROGRAMS = \
+ pdfdetach \
pdffonts \
pdfimages \
pdfinfo \
@@ -56,6 +57,7 @@ bin_PROGRAMS = \
$(pdftocairo_binary)
dist_man1_MANS = \
+ pdfdetach.1 \
pdffonts.1 \
pdfimages.1 \
pdfinfo.1 \
@@ -69,6 +71,10 @@ dist_man1_MANS = \
common = parseargs.cc parseargs.h
+pdfdetach_SOURCES = \
+ pdfdetach.cc \
+ $(common)
+
pdffonts_SOURCES = \
pdffonts.cc \
$(common)