summaryrefslogtreecommitdiff
path: root/src/panfrost/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/panfrost/meson.build')
-rw-r--r--src/panfrost/meson.build8
1 files changed, 3 insertions, 5 deletions
diff --git a/src/panfrost/meson.build b/src/panfrost/meson.build
index 9c12ff8fd8e..435c64d354a 100644
--- a/src/panfrost/meson.build
+++ b/src/panfrost/meson.build
@@ -49,9 +49,7 @@ pandecode = executable(
include_directories : [inc_common, inc_include, inc_src, inc_panfrost],
dependencies : [
dep_thread,
- ],
- link_with : [
- libmesa_util
+ idep_mesautil,
],
build_by_default : true
)
@@ -71,11 +69,11 @@ bifrost_compiler = executable(
],
dependencies : [
dep_thread,
- idep_nir
+ idep_nir,
+ idep_mesautil,
],
link_with : [
libglsl_standalone,
- libmesa_util,
libpanfrost_bifrost
],
build_by_default : true