summaryrefslogtreecommitdiff
path: root/src/mesa/drivers/dri/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/mesa/drivers/dri/common/meson.build')
-rw-r--r--src/mesa/drivers/dri/common/meson.build39
1 files changed, 0 insertions, 39 deletions
diff --git a/src/mesa/drivers/dri/common/meson.build b/src/mesa/drivers/dri/common/meson.build
deleted file mode 100644
index d2d063a8cc1..00000000000
--- a/src/mesa/drivers/dri/common/meson.build
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright © 2017 Intel Corporation
-
-# Permission is hereby granted, free of charge, to any person obtaining a copy
-# of this software and associated documentation files (the "Software"), to deal
-# in the Software without restriction, including without limitation the rights
-# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-# copies of the Software, and to permit persons to whom the Software is
-# furnished to do so, subject to the following conditions:
-
-# The above copyright notice and this permission notice shall be included in
-# all copies or substantial portions of the Software.
-
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-# SOFTWARE.
-
-inc_dri_common = include_directories('.')
-
-libdricommon = static_library(
- 'dricommon',
- files('utils.c', 'utils.h', 'dri_util.c', 'dri_util.h'),
- include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux, inc_util],
- gnu_symbol_visibility : 'hidden',
- dependencies : [dep_libdrm, idep_mesautil],
- build_by_default : false,
-)
-
-libmegadriver_stub = static_library(
- 'megadriver_stub',
- 'megadriver_stub.c',
- include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
- gnu_symbol_visibility : 'hidden',
- dependencies : dep_libdrm,
- build_by_default : false,
-)