summaryrefslogtreecommitdiff
path: root/src/mapi/vgapi/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/mapi/vgapi/Makefile.am')
-rw-r--r--src/mapi/vgapi/Makefile.am61
1 files changed, 0 insertions, 61 deletions
diff --git a/src/mapi/vgapi/Makefile.am b/src/mapi/vgapi/Makefile.am
deleted file mode 100644
index 45ef4b2d01a..00000000000
--- a/src/mapi/vgapi/Makefile.am
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright © 2012 Intel Corporation
-#
-# Permission is hereby granted, free of charge, to any person obtaining a
-# copy of this software and associated documentation files (the "Software"),
-# to deal in the Software without restriction, including without limitation
-# the rights to use, copy, modify, merge, publish, distribute, sublicense,
-# and/or sell copies of the Software, and to permit persons to whom the
-# Software is furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice (including the next
-# paragraph) shall be included in all copies or substantial portions of the
-# Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
-# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
-# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
-# IN THE SOFTWARE.
-
-AM_CPPFLAGS = \
- $(DEFINES) \
- $(SELINUX_CFLAGS) \
- -I$(top_srcdir)/include \
- -I$(top_srcdir)/src/mapi \
- -DMAPI_ABI_HEADER=\"vgapi_tmp.h\"
-
-AM_CFLAGS = $(VISIBILITY_CFLAGS)
-
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = vg.pc
-
-VG_includedir = $(includedir)/VG
-VG_include_HEADERS = \
- $(top_srcdir)/include/VG/openvg.h \
- $(top_srcdir)/include/VG/vgext.h \
- $(top_srcdir)/include/VG/vgplatform.h \
- $(top_srcdir)/include/VG/vgu.h
-
-lib_LTLIBRARIES = libOpenVG.la
-
-TOP=$(top_srcdir)
-include ../Makefile.sources
-libOpenVG_la_SOURCES = $(MAPI_FILES) vgapi_tmp.h
-libOpenVG_la_LIBADD = $(VG_LIB_DEPS)
-libOpenVG_la_LDFLAGS = \
- -no-undefined \
- -version-number 1 \
- $(GC_SECTIONS) \
- $(LD_NO_UNDEFINED)
-
-vgapi_tmp.h: $(srcdir)/vgapi.csv $(top_srcdir)/src/mapi/mapi_abi.py
- $(AM_V_GEN) $(PYTHON2) $(PYTHON_FLAGS) $(top_srcdir)/src/mapi/mapi_abi.py \
- --printer vgapi --mode lib $< > $@
-
-EXTRA_DIST = SConscript vgapi.csv
-BUILT_SOURCES = vgapi_tmp.h
-CLEANFILES = $(BUILT_SOURCES)
-
-include $(top_srcdir)/install-lib-links.mk