summaryrefslogtreecommitdiff
path: root/src/mapi/shared-glapi/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/mapi/shared-glapi/meson.build')
-rw-r--r--src/mapi/shared-glapi/meson.build19
1 files changed, 10 insertions, 9 deletions
diff --git a/src/mapi/shared-glapi/meson.build b/src/mapi/shared-glapi/meson.build
index fe0d458d934..c7d136ced2c 100644
--- a/src/mapi/shared-glapi/meson.build
+++ b/src/mapi/shared-glapi/meson.build
@@ -51,14 +51,15 @@ libglapi = shared_library(
)
if with_tests
- shared_glapi_test = executable(
- ['shared-glapi-test', glapitable_h],
- 'tests/check_table.cpp',
- cpp_args : [cpp_msvc_compat_args],
- include_directories : [inc_src, inc_include, inc_mapi],
- link_with : [libglapi],
- dependencies : [dep_thread, idep_gtest],
+ test(
+ 'shared-glapi-test',
+ executable(
+ ['shared-glapi-test', glapitable_h],
+ 'tests/check_table.cpp',
+ cpp_args : [cpp_msvc_compat_args],
+ include_directories : [inc_src, inc_include, inc_mapi],
+ link_with : [libglapi],
+ dependencies : [dep_thread, idep_gtest],
+ )
)
-
- test('shared-glapi-test', shared_glapi_test)
endif