summaryrefslogtreecommitdiff
path: root/src/gallium/targets/radeonsi/omx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/radeonsi/omx/Makefile.am')
-rw-r--r--src/gallium/targets/radeonsi/omx/Makefile.am8
1 files changed, 1 insertions, 7 deletions
diff --git a/src/gallium/targets/radeonsi/omx/Makefile.am b/src/gallium/targets/radeonsi/omx/Makefile.am
index c2065cf8926..439e91c0578 100644
--- a/src/gallium/targets/radeonsi/omx/Makefile.am
+++ b/src/gallium/targets/radeonsi/omx/Makefile.am
@@ -36,6 +36,7 @@ AM_CPPFLAGS = \
omxdir = $(OMX_LIB_INSTALL_DIR)
omx_LTLIBRARIES = libomx_radeonsi.la
+nodist_EXTRA_libomx_radeonsi_la_SOURCES = dummy.cpp
libomx_radeonsi_la_SOURCES = \
drm_target.c \
$(top_srcdir)/src/gallium/auxiliary/vl/vl_winsys_dri.c
@@ -49,10 +50,3 @@ libomx_radeonsi_la_LIBADD = \
$(GALLIUM_OMX_LIB_DEPS) \
$(LIBDRM_LIBS) \
$(RADEON_LIBS)
-
-if HAVE_MESA_LLVM
-libomx_radeonsi_la_LINK = $(CXXLINK) $(libomx_radeonsi_la_LDFLAGS)
-# Mention a dummy pure C++ file to trigger generation of the $(LINK) variable
-nodist_EXTRA_libomx_radeonsi_la_SOURCES = dummy-cpp.cpp
-
-endif