summaryrefslogtreecommitdiff
path: root/src/gallium/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/meson.build')
-rw-r--r--src/gallium/meson.build12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/gallium/meson.build b/src/gallium/meson.build
index a3679e5ef62..5b0ce81d1e4 100644
--- a/src/gallium/meson.build
+++ b/src/gallium/meson.build
@@ -89,6 +89,12 @@ if with_gallium_vc4
else
driver_vc4 = declare_dependency()
endif
+if with_gallium_etnaviv
+ subdir('winsys/etnaviv/drm')
+ subdir('drivers/etnaviv')
+else
+ driver_etnaviv = declare_dependency()
+endif
if with_gallium_kmsro
subdir('winsys/kmsro/drm')
else
@@ -100,12 +106,6 @@ if with_gallium_v3d
else
driver_v3d = declare_dependency()
endif
-if with_gallium_etnaviv
- subdir('winsys/etnaviv/drm')
- subdir('drivers/etnaviv')
-else
- driver_etnaviv = declare_dependency()
-endif
if with_gallium_imx
subdir('winsys/imx/drm')
else