summaryrefslogtreecommitdiff
path: root/src/gallium/frontends/osmesa/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/frontends/osmesa/meson.build')
-rw-r--r--src/gallium/frontends/osmesa/meson.build36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/gallium/frontends/osmesa/meson.build b/src/gallium/frontends/osmesa/meson.build
new file mode 100644
index 00000000000..e5848fd9934
--- /dev/null
+++ b/src/gallium/frontends/osmesa/meson.build
@@ -0,0 +1,36 @@
+# Copyright © 2017-2018 Intel Corporation
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+osmesa_st_c_args = []
+if with_platform_windows
+ osmesa_st_c_args += ['-DBUILD_GL32', '-DWIN32_LEAN_AND_MEAN']
+ if not with_shared_glapi
+ osmesa_st_c_args += ['-D_GLAPI_NO_EXPORTS']
+ endif
+endif
+
+libosmesa_st = static_library(
+ 'osmesa_st',
+ 'osmesa.c',
+ c_args : osmesa_st_c_args,
+ include_directories : [
+ inc_include, inc_src, inc_gallium, inc_gallium_aux, inc_mapi, inc_mesa,
+ ],
+)