summaryrefslogtreecommitdiff
path: root/src/gallium/drivers/v3d/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/v3d/meson.build')
-rw-r--r--src/gallium/drivers/v3d/meson.build12
1 files changed, 0 insertions, 12 deletions
diff --git a/src/gallium/drivers/v3d/meson.build b/src/gallium/drivers/v3d/meson.build
index 093eb12e01b..033ff402321 100644
--- a/src/gallium/drivers/v3d/meson.build
+++ b/src/gallium/drivers/v3d/meson.build
@@ -47,16 +47,6 @@ files_per_version = files(
'v3dx_state.c',
)
-v3d_driinfo_h = custom_target(
- 'v3d_driinfo.h',
- input : files(
- '../../../util/merge_driinfo.py',
- '../../auxiliary/pipe-loader/driinfo_gallium.h', 'driinfo_v3d.h'
- ),
- output : 'v3d_driinfo.h',
- command : [prog_python, '@INPUT@'],
- capture : true,
-)
v3d_args = ['-DV3D_BUILD_NEON']
dep_v3dv3 = dependency('v3dv3', required: false)
@@ -104,7 +94,6 @@ libv3d = static_library(
[
files_libv3d,
v3d_xml_pack,
- v3d_driinfo_h
],
include_directories : [
inc_src, inc_include, inc_gallium, inc_gallium_aux, inc_broadcom,
@@ -120,6 +109,5 @@ libv3d = static_library(
driver_v3d = declare_dependency(
compile_args : '-DGALLIUM_V3D',
link_with : [libv3d, libv3dwinsys, libbroadcom_cle, libbroadcom_v3d],
- sources : v3d_driinfo_h,
dependencies : idep_nir,
)