summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2015-07-17 10:21:06 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2015-09-09 12:48:09 +0100
commitd65bd7a7be48d7805f68cd45218794f3e4590408 (patch)
treebe7ed440ba7b3dfd9b6073f55ceea5ac5c31230a /src/util/Makefile.am
parentc8984a7a4686c2045666d32fbe5733ff5a5c3bd8 (diff)
util: automake: rework the format_srgb.c rule
A handful of changes/cleanups paving the way to bmake support: - Remove optional $(srcdir)/ prefix for files in the prereq list. - Drop the space after the AM_V_GEN variable. - Using $< in a non-suffix rule is a GNU make idiom. - Use $(@D) over $(dir $@). The latter is a POSIX standard. v2: Cosmetic tweaks in the commit summary. Cc: 11.0 <mesa-stable@lists.freedesktop.org> Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Matt Turner <mattst88@gmail.com> (v1)
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 761023d186f..e05a2c5958c 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -55,5 +55,7 @@ BUILT_SOURCES = $(MESA_UTIL_GENERATED_FILES)
CLEANFILES = $(BUILT_SOURCES)
EXTRA_DIST = format_srgb.py SConscript
-format_srgb.c: $(srcdir)/format_srgb.py
- $(AM_V_GEN) $(PYTHON2) $< > $@
+PYTHON_GEN = $(AM_V_GEN)$(PYTHON2) $(PYTHON_FLAGS)
+
+format_srgb.c: format_srgb.py
+ $(PYTHON_GEN) $(srcdir)/format_srgb.py > $@