summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorMark Janes <mark.a.janes@intel.com>2015-03-04 16:37:29 -0800
committerMatt Turner <mattst88@gmail.com>2015-03-05 10:21:40 -0800
commit237dcb4aa7c39c59bfd225ae3d73caf709be216d (patch)
tree9139b596ac2383fa3e4ada351b94000ba9319e5f /src/util/Makefile.am
parent2e4c95dfe2cb205c327ceaa12b44a9273bdb20dc (diff)
Fix invalid extern "C" around header inclusion.
System headers may contain C++ declarations, which cannot be given C linkage. For this reason, include statements should never occur inside extern "C". This patch moves the C linkage statements to enclose only the declarations within a single header. Reviewed-by: Jose Fonseca <jfonseca@vmware.com>
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 29b66e70e9d..ec49dc6cf16 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -25,6 +25,9 @@ include Makefile.sources
noinst_LTLIBRARIES = libmesautil.la
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include
+
libmesautil_la_CPPFLAGS = \
$(DEFINES) \
-I$(top_srcdir)/include \