summaryrefslogtreecommitdiff
path: root/src/mesa/drivers/dri/i965/meson.build
diff options
context:
space:
mode:
authorJason Ekstrand <jason.ekstrand@intel.com>2018-05-04 22:32:24 -0700
committerJason Ekstrand <jason.ekstrand@intel.com>2018-05-08 08:27:44 -0700
commitbdbb527a65fc729e7a9319ae67de60d03d06c3fd (patch)
tree130ced88b4416251d9e77174a547431c302038ec /src/mesa/drivers/dri/i965/meson.build
parentccd3dce3c059ad6d24ab50107ac6bb8827f46c3d (diff)
i965: Use ISL for emitting depth/stencil/hiz state on gen6+
We leave gen4-5 alone because the ISL code hasn't really been well- tested on gen4-5 or with combined depth-stencil because we don't use BLORP for depth operations on gen4-5. Also, the gen4-5 code has to deal with intratile offsets for LOD hacks and ISL doesn't handle those yet. We could make ISL handle gen4-5 capable or we could just not bother. Among other things, this should make future platform enabling easier because it means we don't have to update multiple (or hand-rolled!) depth stencil emit paths. Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>
Diffstat (limited to 'src/mesa/drivers/dri/i965/meson.build')
-rw-r--r--src/mesa/drivers/dri/i965/meson.build2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/mesa/drivers/dri/i965/meson.build b/src/mesa/drivers/dri/i965/meson.build
index a2c1896fecb..20404d5b059 100644
--- a/src/mesa/drivers/dri/i965/meson.build
+++ b/src/mesa/drivers/dri/i965/meson.build
@@ -87,14 +87,12 @@ files_i965 = files(
'gen4_blorp_exec.h',
'gen6_clip_state.c',
'gen6_constant_state.c',
- 'gen6_depth_state.c',
'gen6_multisample_state.c',
'gen6_queryobj.c',
'gen6_sampler_state.c',
'gen6_sol.c',
'gen6_urb.c',
'gen7_l3_state.c',
- 'gen7_misc_state.c',
'gen7_sol_state.c',
'gen7_urb.c',
'gen8_depth_state.c',