summaryrefslogtreecommitdiff
path: root/src/mesa/drivers/dri/i965/Makefile.am
diff options
context:
space:
mode:
authorJason Ekstrand <jason.ekstrand@intel.com>2016-08-08 14:07:12 -0700
committerJason Ekstrand <jason.ekstrand@intel.com>2016-08-19 03:11:29 -0700
commitc8bc1ae96a2980f33cf770b909ab9d7e830e95bc (patch)
tree03eb8d54af9d5095ec122bba95382b8c0f96fada /src/mesa/drivers/dri/i965/Makefile.am
parenteea6a66222c0f4d59bb29388b275a3520dd652be (diff)
i965: Move gen6_blorp.c to a file that gets recompiled per-gen
At the moment, it's only used for gen6 but that will change soon. We use the genX prefix for recompiled things in the Vulkan driver. It isn't great, but it seems to have worked ok. Signed-off-by: Jason Ekstrand <jason@jlekstrand.net> Reviewed-by: Topi Pohjolainen <topi.pohjolainen@intel.com>
Diffstat (limited to 'src/mesa/drivers/dri/i965/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/i965/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/src/mesa/drivers/dri/i965/Makefile.am b/src/mesa/drivers/dri/i965/Makefile.am
index 77ad1e84c45..02e46ad1289 100644
--- a/src/mesa/drivers/dri/i965/Makefile.am
+++ b/src/mesa/drivers/dri/i965/Makefile.am
@@ -48,11 +48,22 @@ brw_nir_trig_workarounds.c: brw_nir_trig_workarounds.py $(top_srcdir)/src/compil
$(MKDIR_GEN)
$(AM_V_GEN) PYTHONPATH=$(top_srcdir)/src/compiler/nir $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/brw_nir_trig_workarounds.py > $@ || ($(RM) $@; false)
-noinst_LTLIBRARIES = libi965_dri.la libi965_compiler.la
+I965_PERGEN_LIBS = \
+ libi965_gen6.la
+
+libi965_gen6_la_SOURCES = $(i965_gen6_FILES)
+libi965_gen6_la_CFLAGS = $(AM_CFLAGS) -DGEN_VERSIONx10=60
+
+noinst_LTLIBRARIES = \
+ libi965_dri.la \
+ libi965_compiler.la \
+ $(I965_PERGEN_LIBS)
+
libi965_dri_la_SOURCES = $(i965_FILES)
libi965_dri_la_LIBADD = \
$(top_builddir)/src/intel/isl/libisl.la \
libi965_compiler.la \
+ $(I965_PERGEN_LIBS) \
$(INTEL_LIBS)
libi965_compiler_la_SOURCES = \
@@ -67,6 +78,7 @@ EXTRA_DIST = \
TEST_LIBS = \
libi965_compiler.la \
+ $(I965_PERGEN_LIBS) \
$(top_builddir)/src/compiler/nir/libnir.la \
$(top_builddir)/src/util/libmesautil.la \
$(top_builddir)/src/intel/isl/libisl.la \