summaryrefslogtreecommitdiff
path: root/src/mesa/drivers/dri/i965/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2012-09-21 10:10:54 +0200
committerEric Anholt <eric@anholt.net>2012-09-27 12:52:53 -0700
commit837f06b42fd46fdfdc0c85734dbad5497ea6d19f (patch)
tree23ee5aef46737088e58126c623ab2ec44df16dd6 /src/mesa/drivers/dri/i965/Makefile.am
parent0f331bd385ccec539a26f6daf07acbc0e5e56d08 (diff)
i965: Use visibility cflags on the driver code.
The only symbols that need to be public (those in intel_screen.c that the loader looks for) are already marked public. Saves 100k of compiled driver size. Reviewed-by: Kenneth Graunke <kenneth@whitecape.org> Reviewed-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'src/mesa/drivers/dri/i965/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/i965/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/mesa/drivers/dri/i965/Makefile.am b/src/mesa/drivers/dri/i965/Makefile.am
index 5bb62c49efd..574a4992e7a 100644
--- a/src/mesa/drivers/dri/i965/Makefile.am
+++ b/src/mesa/drivers/dri/i965/Makefile.am
@@ -38,6 +38,7 @@ AM_CFLAGS = \
-I$(top_srcdir)/src/mesa/drivers/dri/intel/server \
$(DEFINES) \
$(API_DEFINES) \
+ $(VISIBILITY_CFLAGS) \
$(INTEL_CFLAGS)
AM_CXXFLAGS = $(AM_CFLAGS)