summaryrefslogtreecommitdiff
path: root/src/mesa/drivers/dri/i965/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2014-04-07 11:40:39 -0700
committerEric Anholt <eric@anholt.net>2014-04-08 00:59:48 -0700
commit57d6e7b7ee1a5f4c326b4383b388d3ead7f99c43 (patch)
tree093ac12a0fbc3f269eb031c958a93b153fc8fc2f /src/mesa/drivers/dri/i965/Makefile.am
parent6230b646a5a3f100f4d3dc05dff6c3ace85ee96c (diff)
i965/vec4: Add a test for copy propagation behavior.
I thought I was seeing a bug in the code while reviewing, but it's not there. Reviewed-by: Ian Romanick <ian.d.romanick@intel.com>
Diffstat (limited to 'src/mesa/drivers/dri/i965/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/i965/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/mesa/drivers/dri/i965/Makefile.am b/src/mesa/drivers/dri/i965/Makefile.am
index 54a38bdbd43..7ab376cc12f 100644
--- a/src/mesa/drivers/dri/i965/Makefile.am
+++ b/src/mesa/drivers/dri/i965/Makefile.am
@@ -55,6 +55,7 @@ TEST_LIBS = \
TESTS = \
test_eu_compact \
+ test_vec4_copy_propagation \
test_vec4_register_coalesce \
test_blorp_blit_eu_gen
@@ -66,6 +67,12 @@ test_vec4_register_coalesce_LDADD = \
$(TEST_LIBS) \
$(top_builddir)/src/gtest/libgtest.la
+test_vec4_copy_propagation_SOURCES = \
+ test_vec4_copy_propagation.cpp
+test_vec4_copy_propagation_LDADD = \
+ $(TEST_LIBS) \
+ $(top_builddir)/src/gtest/libgtest.la
+
test_eu_compact_SOURCES = \
test_eu_compact.c
nodist_EXTRA_test_eu_compact_SOURCES = dummy.cpp