summaryrefslogtreecommitdiff
path: root/src/mesa/drivers/dri/i965/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2012-10-01 13:00:18 -0700
committerMatt Turner <mattst88@gmail.com>2012-10-03 13:41:09 -0700
commit31ab61cac10bf75210134b6d8a354ac3cbd3b4da (patch)
tree5c83b24f296935a55466b7188e1780ac0890de93 /src/mesa/drivers/dri/i965/Makefile.am
parent551c991606e543c3a264a762026f11348b37947e (diff)
dri drivers: Link dricommon before dynamic libraries
I think libtool should be handling this for us, but the build fails for Jordan because libdricommon (a static library, which uses expat) appears before -lexpat on the linker command. Reviewed-by: Jordan Justen <jordan.l.justen@intel.com> Tested-by: Jordan Justen <jordan.l.justen@intel.com>
Diffstat (limited to 'src/mesa/drivers/dri/i965/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/i965/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/mesa/drivers/dri/i965/Makefile.am b/src/mesa/drivers/dri/i965/Makefile.am
index 574a4992e7a..2cdfb515f53 100644
--- a/src/mesa/drivers/dri/i965/Makefile.am
+++ b/src/mesa/drivers/dri/i965/Makefile.am
@@ -55,9 +55,9 @@ libi965_dri_la_SOURCES = \
# list of libs to be linked against by i965_dri.so and i965 test programs.
COMMON_LIBS = \
libi965_dri.la \
+ ../common/libdricommon.la \
$(DRI_LIB_DEPS) \
- $(INTEL_LIBS) \
- ../common/libdricommon.la
+ $(INTEL_LIBS)
TEST_LIBS = \
$(COMMON_LIBS) \