summaryrefslogtreecommitdiff
path: root/src/mesa/drivers/dri/i965/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2015-02-21 22:41:24 -0800
committerMatt Turner <mattst88@gmail.com>2015-02-23 10:41:21 -0800
commit0b6d43e329d194b01ab5cd554617f79a13f6669a (patch)
treedfa1e52cc4e8ec8c667ddbea62b89015524f93d2 /src/mesa/drivers/dri/i965/Makefile.am
parent5dc6c8c570a11a3e4bf3142b54cd618e9c66b51b (diff)
i965: Link test programs with gtest before pthreads.
Cc: "10.5" <mesa-stable@lists.freedesktop.org> Bugzilla: https://bugs.gentoo.org/show_bug.cgi?id=540962
Diffstat (limited to 'src/mesa/drivers/dri/i965/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/i965/Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/src/mesa/drivers/dri/i965/Makefile.am b/src/mesa/drivers/dri/i965/Makefile.am
index 9230a49308b..235bcfeae02 100644
--- a/src/mesa/drivers/dri/i965/Makefile.am
+++ b/src/mesa/drivers/dri/i965/Makefile.am
@@ -67,32 +67,32 @@ check_PROGRAMS = $(TESTS)
test_fs_cmod_propagation_SOURCES = \
test_fs_cmod_propagation.cpp
test_fs_cmod_propagation_LDADD = \
- $(TEST_LIBS) \
- $(top_builddir)/src/gtest/libgtest.la
+ $(top_builddir)/src/gtest/libgtest.la \
+ $(TEST_LIBS)
test_fs_saturate_propagation_SOURCES = \
test_fs_saturate_propagation.cpp
test_fs_saturate_propagation_LDADD = \
- $(TEST_LIBS) \
- $(top_builddir)/src/gtest/libgtest.la
+ $(top_builddir)/src/gtest/libgtest.la \
+ $(TEST_LIBS)
test_vf_float_conversions_SOURCES = \
test_vf_float_conversions.cpp
test_vf_float_conversions_LDADD = \
- $(TEST_LIBS) \
- $(top_builddir)/src/gtest/libgtest.la
+ $(top_builddir)/src/gtest/libgtest.la \
+ $(TEST_LIBS)
test_vec4_register_coalesce_SOURCES = \
test_vec4_register_coalesce.cpp
test_vec4_register_coalesce_LDADD = \
- $(TEST_LIBS) \
- $(top_builddir)/src/gtest/libgtest.la
+ $(top_builddir)/src/gtest/libgtest.la \
+ $(TEST_LIBS)
test_vec4_copy_propagation_SOURCES = \
test_vec4_copy_propagation.cpp
test_vec4_copy_propagation_LDADD = \
- $(TEST_LIBS) \
- $(top_builddir)/src/gtest/libgtest.la
+ $(top_builddir)/src/gtest/libgtest.la \
+ $(TEST_LIBS)
test_eu_compact_SOURCES = \
test_eu_compact.c