summaryrefslogtreecommitdiff
path: root/src/mesa/drivers/dri/i965/Makefile.am
diff options
context:
space:
mode:
authorJason Ekstrand <jason.ekstrand@intel.com>2016-05-25 17:51:59 -0700
committerJason Ekstrand <jason.ekstrand@intel.com>2016-05-26 14:13:38 -0700
commit057259655e79f6adfa79b71b0ee181dcae5454de (patch)
tree20cf8e79175474b6001ba6bb0b4617c37c935c95 /src/mesa/drivers/dri/i965/Makefile.am
parent870ff6cd3829b1f15f1aa636be17c1ffb371a290 (diff)
i965: Don't link libmesa or libdri_test_stubs into tests
Now that the compiler has been completely separated from libmesa, we no longer need these. We can make the tests much smaller by not linking them in. This also ensures that anyone who runs make check won't accidentally put in any dependencies from the compiler to the rest of mesa core. Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Kristian Høgsberg <krh@bitplanet.net>
Diffstat (limited to 'src/mesa/drivers/dri/i965/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/i965/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/mesa/drivers/dri/i965/Makefile.am b/src/mesa/drivers/dri/i965/Makefile.am
index 9a990d21f8d..0a5222ec48a 100644
--- a/src/mesa/drivers/dri/i965/Makefile.am
+++ b/src/mesa/drivers/dri/i965/Makefile.am
@@ -66,11 +66,11 @@ EXTRA_DIST = \
TEST_LIBS = \
libi965_compiler.la \
- ../../../libmesa.la \
+ $(top_builddir)/src/compiler/nir/libnir.la \
+ $(top_builddir)/src/util/libmesautil.la \
$(top_builddir)/src/intel/isl/libisl.la \
$(PTHREAD_LIBS) \
- $(DLOPEN_LIBS) \
- ../common/libdri_test_stubs.la
+ $(DLOPEN_LIBS)
TESTS = \
test_fs_cmod_propagation \