summaryrefslogtreecommitdiff
path: root/src/mesa/drivers/dri/Makefile.am
diff options
context:
space:
mode:
authorErik Faye-Lund <kusmabite@gmail.com>2015-06-10 23:35:04 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2015-06-12 15:32:18 +0100
commit634f2002563b4fca68490c0a39518ea838f28fb1 (patch)
tree8e64647bd1347bcd64a7915de6b7eb08397cfdd8 /src/mesa/drivers/dri/Makefile.am
parent83b5648a1e0b7c21536af18c0d29da2f2a31215e (diff)
mesa: build xmlconfig to a separate static library
As we use the file from both the dri modules and loader, we end up with multiple definition of the symbols provided in our gallium dri modules. Additionally we compile the file twice. Resolve both issues, effectively enabling the build on toolchains which don't support -Wl,--allow-multiple-definition. v2: [Emil Velikov] - Fix the Scons/Android build. - Resolve libgbm build issues (bring back the missing -lm) Cc: Julien Isorce <j.isorce@samsung.com> Cc: "10.5 10.6" <mesa-stable@lists.freedesktop.org> Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=90310 Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=90905 Acked-by: Matt Turner <mattst88@gmail.com> Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com>
Diffstat (limited to 'src/mesa/drivers/dri/Makefile.am')
-rw-r--r--src/mesa/drivers/dri/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/mesa/drivers/dri/Makefile.am b/src/mesa/drivers/dri/Makefile.am
index fa1de103b56..08a8e645521 100644
--- a/src/mesa/drivers/dri/Makefile.am
+++ b/src/mesa/drivers/dri/Makefile.am
@@ -60,6 +60,7 @@ mesa_dri_drivers_la_LIBADD = \
../../libmesa.la \
common/libmegadriver_stub.la \
common/libdricommon.la \
+ common/libxmlconfig.la \
$(MEGADRIVERS_DEPS) \
$(DRI_LIB_DEPS) \
$()