summaryrefslogtreecommitdiff
path: root/src/mapi/glapi/gen/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <ian.d.romanick@intel.com>2015-05-08 18:50:11 -0700
committerIan Romanick <ian.d.romanick@intel.com>2015-05-15 20:22:26 -0700
commitd649fcf727bffa11a5426ebcf38f51f478664b17 (patch)
treea9d96cab5b6f615ae296cce8ce945ef60c8ec7d6 /src/mapi/glapi/gen/Makefile.am
parent5aaabd7630ca6fd72a3333687249574e6fcbe663 (diff)
glapi: Store static dispatch offsets in a separate table
Since the set of functions with static will never change, there is no reason to store it in the XML. It's just one of those fields that confuses people adding new functions. This is split out from the rest of the series so that in-code assertions can be used to verify that the data in the Python code matches the XML. Signed-off-by: Ian Romanick <ian.d.romanick@intel.com> Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Dylan Baker <baker.dylan.c@gmail.com>
Diffstat (limited to 'src/mapi/glapi/gen/Makefile.am')
-rw-r--r--src/mapi/glapi/gen/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/mapi/glapi/gen/Makefile.am b/src/mapi/glapi/gen/Makefile.am
index c8d41746887..4d23f825c92 100644
--- a/src/mapi/glapi/gen/Makefile.am
+++ b/src/mapi/glapi/gen/Makefile.am
@@ -75,6 +75,7 @@ EXTRA_DIST= \
glX_proto_size.py \
glX_server_table.py \
remap_helper.py \
+ static_data.py \
SConscript \
gl_API.dtd
@@ -197,6 +198,7 @@ COMMON = $(API_XML) \
gl_XML.py \
glX_XML.py \
license.py \
+ static_data.py \
typeexpr.py
COMMON_GLX = $(COMMON) glX_API.xml glX_XML.py glX_proto_common.py