summaryrefslogtreecommitdiff
path: root/src/intel/isl/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-07-22 14:50:15 +0100
committerEric Engestrom <eric@engestrom.ch>2019-08-03 00:08:37 +0000
commitd2d85b950d78c553b2694cda9ef0cc7bf9a0f737 (patch)
treeafdd28e30b66064b8b540a6e9d6d0ecbe27a6678 /src/intel/isl/meson.build
parent8ddb38209d51c53d6e5792b04b97814dfce9bce6 (diff)
meson: replace libmesa_util with idep_mesautil
This automates the include_directories and dependencies tracking so that all users of libmesa_util don't need to add them manually. Next commit will remove the ones that were only added for that reason. Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Acked-by: Eric Anholt <eric@anholt.net> Tested-by: Vinson Lee <vlee@freedesktop.org>
Diffstat (limited to 'src/intel/isl/meson.build')
-rw-r--r--src/intel/isl/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/intel/isl/meson.build b/src/intel/isl/meson.build
index 9117afb4228..88070749879 100644
--- a/src/intel/isl/meson.build
+++ b/src/intel/isl/meson.build
@@ -126,9 +126,9 @@ if with_tests
executable(
'isl_surf_get_image_offset_test',
'tests/isl_surf_get_image_offset_test.c',
- dependencies : dep_m,
+ dependencies : [dep_m, idep_mesautil],
include_directories : [inc_common, inc_intel],
- link_with : [libisl, libintel_dev, libmesa_util],
+ link_with : [libisl, libintel_dev],
),
suite : ['intel'],
)