summaryrefslogtreecommitdiff
path: root/src/gallium/targets/opencl/meson.build
diff options
context:
space:
mode:
authorKarol Herbst <kherbst@redhat.com>2020-04-02 13:00:14 +0200
committerMarge Bot <eric+marge@anholt.net>2020-04-03 04:07:38 +0000
commitff1a3a00cb37d84ab9a563f0aa241714876f56b4 (patch)
treeab4d980ba549ea9b198545f9e9b28a4eebb52a7f /src/gallium/targets/opencl/meson.build
parent2243f0cd0178fdc5063d049f192b4365122207b9 (diff)
clover: fix build with single library clang build
Closes: #2560 Signed-off-by: Karol Herbst <kherbst@redhat.com> Reviewed-by: Michel Dänzer <mdaenzer@redhat.com> Tested-by: Marge Bot <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4417> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4417>
Diffstat (limited to 'src/gallium/targets/opencl/meson.build')
-rw-r--r--src/gallium/targets/opencl/meson.build26
1 files changed, 16 insertions, 10 deletions
diff --git a/src/gallium/targets/opencl/meson.build b/src/gallium/targets/opencl/meson.build
index 907cc74337d..6ce01025d0b 100644
--- a/src/gallium/targets/opencl/meson.build
+++ b/src/gallium/targets/opencl/meson.build
@@ -33,16 +33,9 @@ llvm_libdir = dep_llvm.get_configtool_variable('libdir')
opencl_libname = with_opencl_icd ? 'MesaOpenCL' : 'OpenCL'
-libopencl = shared_library(
- opencl_libname,
- [],
- link_args : [ld_args_gc_sections, opencl_link_args],
- link_depends : opencl_link_deps,
- link_whole : libclover,
- link_with : [libpipe_loader_dynamic, libgallium],
- dependencies : [
- idep_mesautil,
- dep_clock, dep_dl, dep_unwind, dep_elf,
+dep_clang = cpp.find_library('clang-cpp', dirs : llvm_libdir, required : false)
+if not dep_clang.found()
+ dep_clang = [
cpp.find_library('clangCodeGen', dirs : llvm_libdir),
cpp.find_library('clangFrontendTool', dirs : llvm_libdir),
cpp.find_library('clangFrontend', dirs : llvm_libdir),
@@ -56,6 +49,19 @@ libopencl = shared_library(
cpp.find_library('clangEdit', dirs : llvm_libdir),
cpp.find_library('clangLex', dirs : llvm_libdir),
cpp.find_library('clangBasic', dirs : llvm_libdir),
+ ]
+endif
+
+libopencl = shared_library(
+ opencl_libname,
+ [],
+ link_args : [ld_args_gc_sections, opencl_link_args],
+ link_depends : opencl_link_deps,
+ link_whole : libclover,
+ link_with : [libpipe_loader_dynamic, libgallium],
+ dependencies : [
+ idep_mesautil,
+ dep_clock, dep_dl, dep_unwind, dep_elf, dep_clang
],
version : '@0@.0.0'.format(opencl_version),
install : true,