summaryrefslogtreecommitdiff
path: root/src/gallium/targets/opencl/meson.build
diff options
context:
space:
mode:
authorYonggang Luo <luoyonggang@gmail.com>2022-11-08 19:07:35 +0800
committerMarge Bot <emma+marge@anholt.net>2022-11-11 05:38:20 +0000
commitf25d483e1bd493fdf6f0f8148259ed085d705617 (patch)
tree656f23badce8491ad45ee353a2e7aa6821090945 /src/gallium/targets/opencl/meson.build
parenta3b26e2758d7fce890717e2679bd0e25ca1330d2 (diff)
clover: Fixes building with mingw-x86
Cc: mesa-stable Signed-off-by: Yonggang Luo <luoyonggang@gmail.com> Reviewed-by: Jesse Natalie <jenatali@microsoft.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/19610>
Diffstat (limited to 'src/gallium/targets/opencl/meson.build')
-rw-r--r--src/gallium/targets/opencl/meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/gallium/targets/opencl/meson.build b/src/gallium/targets/opencl/meson.build
index b6cbbf2f2b5..89629ded9ba 100644
--- a/src/gallium/targets/opencl/meson.build
+++ b/src/gallium/targets/opencl/meson.build
@@ -85,7 +85,13 @@ if not _shared_llvm or not (dep_clang.found() and dep_clang_usable)
endif
endif
-ocldef = files(opencl_libname + '.def.in')[0]
+ocldef_in = files(opencl_libname + '.def.in')[0]
+ocldef = custom_target(
+ 'ocldef.def',
+ input: ocldef_in,
+ output : 'ocldef.def',
+ command : gen_vs_module_defs_normal_command,
+)
libopencl = shared_library(
opencl_libname,