summaryrefslogtreecommitdiff
path: root/src/gallium/drivers/svga/Makefile.am
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-10-26 15:32:09 -0700
committerDylan Baker <dylan@pnwbakers.com>2017-11-01 15:05:26 -0700
commit6594213cfa332be88551596bf56cf01538339f37 (patch)
tree3d273663c334fa3d715cd8964b73dcfdf46696cc /src/gallium/drivers/svga/Makefile.am
parent1f2640bfa940362c7550cdd065d37555f21c8ae8 (diff)
svga: Use __asm__ instead of asm
__asm__ is portable, and allows the svga driver to be compiled with the c99 standard instead of requiring the gnu99 standard. I have compile tested this with GCC and Clang on Linux. Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Brian Paul <brianp@vmware.com> Tested-by: Brian Paul <brianp@vmware.com>
Diffstat (limited to 'src/gallium/drivers/svga/Makefile.am')
-rw-r--r--src/gallium/drivers/svga/Makefile.am3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/gallium/drivers/svga/Makefile.am b/src/gallium/drivers/svga/Makefile.am
index 1ad5e0f91e6..2e5220e9f27 100644
--- a/src/gallium/drivers/svga/Makefile.am
+++ b/src/gallium/drivers/svga/Makefile.am
@@ -30,9 +30,6 @@ AM_CFLAGS = \
$(GALLIUM_DRIVER_CFLAGS) \
$(MSVC2013_COMPAT_CFLAGS)
-#On some systems -std= must be added to CFLAGS to be the last -std=
-CFLAGS += -std=gnu99
-
noinst_HEADERS = $(SVGA_H_FILES)
noinst_LTLIBRARIES = libsvga.la