summaryrefslogtreecommitdiff
path: root/src/gallium/drivers/softpipe/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-11-10 09:17:08 -0800
committerDylan Baker <dylan@pnwbakers.com>2017-11-13 13:43:12 -0800
commit2bfd34c518134dd656f4f23f3c6c8acb1eeda507 (patch)
treed7146ef7faafc54e40ca82792d35b46e1c55453f /src/gallium/drivers/softpipe/meson.build
parent63b6eb9cb92238e7aff71de680c18f5d1d1bcd91 (diff)
meson: don't use build_by_default for specific gallium drivers
Using build_by_default : false is convenient for dependencies that can be pulled in by various diverse components of the build system, the gallium hardware/software drivers and state trackers do not fit that description. Instead, these should be guarded using the variable that tracks whether that driver should be enabled. This leaves a few helper libraries: trace, rbug, etc, and the generic winsys bits as `build_by_default : false` because there are a large number of gallium components that pull them in. v2: - remove build_by_default from winsys convenience libs as well. v3: - Always put drivers before winsys for consistency Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Tested-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com> (v1) Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'src/gallium/drivers/softpipe/meson.build')
-rw-r--r--src/gallium/drivers/softpipe/meson.build1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/gallium/drivers/softpipe/meson.build b/src/gallium/drivers/softpipe/meson.build
index 0cef15152e2..df23533c72c 100644
--- a/src/gallium/drivers/softpipe/meson.build
+++ b/src/gallium/drivers/softpipe/meson.build
@@ -81,5 +81,4 @@ libsoftpipe = static_library(
files_softpipe,
include_directories : [inc_gallium_aux, inc_gallium, inc_include, inc_src],
c_args : [c_vis_args, c_msvc_compat_args],
- build_by_default : false,
)